Mac Launcher Common Issues

Home Forums Support Forum Launcher Support Mac Launcher Common Issues

This topic contains 35 replies, has 16 voices, and was last updated by  Nathan 2 months, 2 weeks ago.

  • Author
    Posts
  • #2115

    Nathan
    Keymaster

    Hey folks!

    Some common issues and solutions we’ve encountered with the Mac version of the launcher:

    Issue: Launcher crashes shortly after opening
    Solution 1: Move launcher and version file to new folder
    Solution 2: Run launcher with sudo

    Issue: Launcher starts, but shows no version number under launcher heading (among other things breaking)
    Solution: Ensure version file is in the same folder as Launcher

  • #2223

    JonCD
    Participant

    This is where I get to with the launcher
    Cheers
    Jon

  • #2227

    Nathan
    Keymaster

    That’s certainly interesting. Is it just doing that after you run the toolkit?

  • #2357

    JonCD
    Participant

    After launch it goes to above,I can press tabs on the side but because of the large square I can’t really do stuff. Have uploaded a pic after pressing cartographer button and scenario button.
    Cheers,
    Jon
    PS using a rather old mac book pro…2008, might be the problem

  • #2360

    Nathan
    Keymaster

    That’s certainly interesting. Does the square appear in the main menu, or just when the cartographer is open?

  • #2465

    leighpierce90
    Participant

    I’ve found one solution for if the Launch button never goes live, is to create a folder INSIDE the Applications folder and put the launcher in there. For whatever reason it fixes that problem.

    My app path is now /Applications/Launcher/ArkenforgeLuncher.app and everything is smooth as can be, sudo or no.

  • #2467

    leighpierce90
    Participant

    To make an App to run this in sudo automatically do the following.

    1) Open the automator app.
    2) Click make an application
    3)Choose, Run Apple script
    4) Paste this:
    on run
    do shell script “open /Applications/Launcher/ArkenforgeLauncher.app” with administrator privileges
    end run
    5) Save somewhere
    6) Run it

  • #2617

    outlawmoon
    Participant

    This isn’t instantly helpful. What’s sudo?

    I’ll do my due diligence and go research it, but so far it looks like something in Linux.

  • #2637

    shiftier
    Participant

    I’m able to get the launcher going and it says it’s downloading the index file, but there isn’t any visible progress bar and it has been stuck like that for hours. I’ve not been able to get the above script to work although i have moved it to a different folder.

    update – i’ve renamed the folder in applications and moved all the files across so now they seem to download, however the installation fails partway through.

    [P.A.T.C.H. – 06/09/2018 13:25:12] Patching process is started!
    [P.A.T.C.H. – 06/09/2018 13:25:12] Cleaning! – Cleaning P.A.T.C.H. workspace!
    [P.A.T.C.H. – 06/09/2018 13:25:12] Checking version… – Found version 1.4.0.0
    [P.A.T.C.H. – 06/09/2018 13:25:12] Version null – False
    [P.A.T.C.H. – 06/09/2018 13:25:12] Checking… – Checking for remote service!
    [P.A.T.C.H. – 06/09/2018 13:25:12] Looking for software – Launcher
    [P.A.T.C.H. – 06/09/2018 13:25:16] Cleaning! – Cleaning P.A.T.C.H. workspace!
    [P.A.T.C.H. – 06/09/2018 13:25:16] No remote patches available!
    [P.A.T.C.H. – 06/09/2018 13:25:53] Patching process is started!
    [P.A.T.C.H. – 06/09/2018 13:25:53] Cleaning! – Cleaning P.A.T.C.H. workspace!
    [P.A.T.C.H. – 06/09/2018 13:25:53] Checking version… – Found version 1.4.0.0
    [P.A.T.C.H. – 06/09/2018 13:25:53] Version null – False
    [P.A.T.C.H. – 06/09/2018 13:25:53] Checking… – Checking for remote service!
    [P.A.T.C.H. – 06/09/2018 13:25:53] Looking for software – MastersToolkitOSX
    [P.A.T.C.H. – 06/09/2018 13:25:57] PatchEntry – 0.2.4.8>0.2.4.9>VRsLcGopYhjjvCPTfwTbO3gzDLs>ZIP
    [P.A.T.C.H. – 06/09/2018 13:25:57] PatchEntry – 0.2.4.9>0.2.4.10>TIufrlrklX7YhSr+S5zQXyR1tQg>ZIP
    [P.A.T.C.H. – 06/09/2018 13:25:57] PatchEntry – 0.2.4.10>0.2.6.5>RBhKIaWwLJWPo8m5CBfd5k5EFz4>ZIP
    [P.A.T.C.H. – 06/09/2018 13:25:57] PatchEntry –
    [P.A.T.C.H. – 06/09/2018 13:25:57] Update to version – 0.2.4.8_0.2.4.9
    [P.A.T.C.H. – 06/09/2018 13:25:57] Update to version – 0.2.4.9_0.2.4.10
    [P.A.T.C.H. – 06/09/2018 13:25:57] Update to version – 0.2.4.10_0.2.6.5
    [P.A.T.C.H. – 06/09/2018 13:25:57] Cleaning! – Cleaning P.A.T.C.H. workspace!
    [P.A.T.C.H. – 06/09/2018 13:25:57] Everything is up to date!

  • #2640

    leighpierce90
    Participant

    @outlaw, mac is run of Unix which is the same backbone as Linux so they share a lot of commands. Sudo allows you to run something with the highest permissions possible.

    @shiftier, have you input your serial? I’ve found that could be the cause.

    At the moment my most comprehensive advice for things to try are as follows.

    TL;DR is, make sure the version file is there, make sure you’ve input your serial, try a few different methods of running it

    MAC USERS:

    Here are a few things I did to get everything up and running smoothly.

    1. Created a folder in my Applications folder called Launcher, and put ALL files (.app and version inclusive) into it. This fixed a “Launch button greyed out” issue I was having.

    Make sure that version file is there with it!!

    2. OPTIONAL if needed, to run the app with sudo. open up terminal and if using the path I detailed above and type “sudo open /Applications/Launcher/ArkenforgeLauncher.app”

    OR use Automator app as above

    3. Run! Most of my issues seemed to be stemming from Launcher location. Once that happened, it was all smooth sailing.

    If you are STILL having issues, make sure you’ve put in your serial number.
    As a last resort you can also try this in terminal, or replace the application path in the Automator script

    OK you can try JUST running this in terminal

    /Applications/Launcher/ArkenforgeLauncher.app/Contents/MacOS/ArkenforgeLauncher

    If that doesn’t work try to prefix it with the open command. What this is doing is running the core program from within the app container.

  • #2641

    Nathan
    Keymaster

    Did you move the version file along with the launcher app?

  • #2645

    shiftier
    Participant

    where do you get the serial number from?

  • #2646

    Prickly Pear
    Participant

    Speaking of serial key…
    Do you need a second serial keys if you want to run MasterToolkit on a second computer?

    I can run MasterToolkit successfully on a cheap windows laptop. No problem there. Now with the MacOS version released, I would like to run MasterToolkit on my desktop iMac. I have added my serial key to Launcher and it says that the key is confirmed, however, I can’t progress from here. If I restart Launcher, it asks for the serial key again… I mean, the “I have a serial key” text is shown at the top of the window. Apart from this, I believe I have installed Launcher correctly since it downloaded all the files at one point (1.3GB of “packs”).
    So, from this I believe that I need a second key or I need to disconnect the serial key from my windows laptop… somehow. Is this correct?

    @shiftier, most of us probably got the serial key as part of the Kickstarter campaign. It was sent to us in an email. I believe you can purchase a key from webpage shop for $25.

  • #2648

    ZsDante
    Keymaster

    Hi there Prickly Pear!

    Kickstarter backers use the key through the Launcher, people who buy it through the website unlock it to their account! In both cases there is no limit how many computers you would like to install the toolkit to, but you can only be logged in on one device at the time!

    You certainly will not need multiple serial keys for the software! The one you received should unlock it on all devices!

  • #2658

    adamgmartin
    Participant

    I got the installer to run, and it did the latest update. But now when I hit the launch button nothing happens. The button is not grayed out and it responds to the click, but it does not do anything.

  • #2664

    Nathan
    Keymaster

    Very curious. Everything definitely seems like it should be running.

    Can you shoot the log file at ~/Library/Logs/Unity/Player.log to nathan@arkenforge.com?

  • #2924

    shiftier
    Participant

    Just to add to the list of “odd things that solved the problem” after trying everything else in the forum I moved the launcher and version file into applications (out of the “MastersToolkit folder I’d put in there) run and downloaded everything for the launcher, then moved the files back. it now seems to be working A-OK

  • #2967

    guidoilparty
    Participant

    I think I’ll add this here, since this is the pinned post about mac launcher problems.

    After trying everything in this thread, this is what worked for me:
    EDIT: problems with the link..
    Just look up for the topic “Mac Launcher is Not Starting”, post 2531

    Quoting from Dusey

    Leigh, you deserve serious props!

    For anyone else out there, Leigh helped me out by suggesting I right click on the application and choose “show contents” and then go to Contents/MacOS/ArkenforgeLauncher and try double clicking that – it worked!

    For anyone else reading this, if that doesn’t work for you, try ‘sudo open’ on this file.

    Thanks for making the DMG for me to try – I just tested it, and unfortunately I got the same result as the official zip. Thanks though!

    Started and downloaded flawlessly after that.

  • #3003

    FGFY
    Participant

    I seem to be able to get this far with some guidance from guidoilparty’s post above. Now what?

  • #3007

    Nathan
    Keymaster

    Can you paste the contents of the log file located at
    ~/Library/Logs/Unity/player.log ?

  • #17148

    DarkSabre
    Participant

    I log in with the launcher app and it says welcome to the forge however nothing else shows. Nothing to launch the master kit, the login button is greyed out, not showing it downloading anything. Running on OSX 10.13.6

  • #17159

    Nathan
    Keymaster

    Interesting!

    Can you shoot through a screenshot?

  • #17253

    DarkSabre
    Participant

    View post on imgur.com

    Yeah not sure what is going on. No crashing, no signs of downloading,

  • #17491

    DarkSabre
    Participant

    Is the Windows Launcher and the Mac Launcher so different?

    The Mac Launcher is 25mb while installing the Windows came out to be 1gb. Am I missing files that I am unaware of for the Mac launcher to work properly?

  • #17527

    kaddielinn
    Participant

    I am having the same issue as DarkSabre

  • #17595

    Nathan
    Keymaster

    Cool. I’m about to update the Mac launcher download to the v3.0 version.

    The Windows launcher has the Essentials and Masters Toolkit build into it, whereas the Mac one just has the launcher.

  • #17604

    Nathan
    Keymaster

    Ok, Launcher is updated on the website 😀
    If you redownload the Launcher from your My Accounts section, you should be all good!

  • #17922

    DarkSabre
    Participant

    New problem.

    Downloaded the new launcher. Launcher says it has a new update. Say yes to update and it closes. No error log or anything.

    Downloaded the master kit, went to launch it, and its stuck loading. Left it for 5 minutes and still wouldn’t load. No error log or anything

  • #18041

    Nathan
    Keymaster

    Yeah, the mac launcher has a couple of issues I need to fix up

  • #18540

    dungeonsandnerds
    Participant

    I just tried to download and install everything for Mac and it’s still having the same issue listed above. It says there is an update and when you say yes, it close the launcher and nothing happens.

    Then when I went back in and clicked on Master’s Toolkit button, nothing happens.

    It shows that it has been downloaded with version number 3 on the button, but clicking on it doesn’t do anything.

  • #18568

    IvanCannon
    Participant

    Hello

    I’ve just purchased the Master ToolKit from your website. I downloaded the Macintosh launcher onto my iMac laptop, and as per the instructions I created a folder in the Applications folder called ‘ArkenforgeLauncher’, and moved ArkenforgeLauncher.app and LauncherPatcher.app to this folder.

    I started the launcher from that folder and it started a window (with very small and hard to read text). It asked me to put in my User name and password, which I did and then it loaded up a bunch of stuff, with Tabs on the top with Software / Shop / Patch Logs / News / Credits. My account name (IvanCannon) is shown in the right corner.

    On the left hand side of that window I clicked on the “Click Below to Install Master Toolkit” button, then a small text above the button says, “Update In Progress” and then the launcher window disappears and I go back to the desktop but nothing happens. Nothing is downloading. There is no Master Toolkit visible. I’ve tried several times but the same thing happens each time.

    What am I doing wrong?

    Ivan Cannon
    elfshadow@iinet.net.au

  • #18587

    DarkSabre
    Participant

    Yeah it won’t even launch the Master Kit or the Pack Maker at all – I bought this specifically because it was a OSX solution instead of Dungeon Painter. I use my Mac for the majority of my graphic editing so it made more sense for me to get the one that had Mac support.

    I know this is still in alpha/early access but it would really be appreciated if this issue could be resolved swiftly if possible about why the Mac Launcher and downloading of updates/packs/etc are having such issues.

  • #18622

    MaineCoon
    Participant

    I’m in same situation, running Sierra (10.12). Just bought it, used sudo to run it:

    sudo “/Applications/ArkenforgeLauncher/ArkenforgeLauncher.app/Contents/MacOS/ArkenforgeLauncher”

    I am able to install the content pack and Masters Toolkit, but it won’t launch the Toolkit. I also tried changing the asset install directory, but this setting doesn’t keep between runs. (Also, download speeds are pretty terrible).

    One dev to another – installing additional assets/applications/etc to “/Applications” is strongly recommended against on macOS. The next iteration of macOS after Mojave probably won’t play nicely at all with the current way Arkenforge is managing itself.

    You should strongly consider using “/Library/Application Support/Arkenforge” (to share between users, but generally not recommended) or “~/Library/Application Support/Arkenforge”. “~/Arkenforge” would be considered acceptable for asset packs and many saved/generated files, considering the large amounts of data, as that makes it easier to clean up. “~/Library/Caches/Arkenforge” for temp data works, but I wouldn’t install asset packs, apps, or anything fairly persistent there.

    This should eliminate the need to run as admin – ArkenforgeLauncher can run the patcher with elevated privileges, letting OS ask for password (see https://developer.apple.com/library/archive/documentation/Security/Conceptual/SecureCodingGuide/Articles/AccessControl.html) – assuming Unity lets you do this.

    These changes will pretty much be necessary going forward as sandboxing is becoming much more standard on OS X.

  • #18645

    leighpierce90
    Participant

    And just to clarify for non Mac/Linux users “~” refers to “/Users/username”, but will work in code nicely.

  • #22487

    shaunk
    Participant

    I’ve been using Arkenforge on my Surface Book 2 largely with no issues, so with the new updates to the launcher, I decided to try my luck on my Hackintosh currently running OSX 10.11.6 with a Geforce GTX970 card.

    Ran ArkenforgeLauncher with sudo, got the same error as last time: I get a black screen after the “Made with Unity” logo, and the application fails to respond, and I have to force quit it. Oddly enough, after this happens, the size of the “Arkenforge” app in my install directory changes from 375mb to 58.5mb? It seems that the ArkenforgeLauncher.app within the package has deleted itself!

    Player.log is below.

    Initialize engine version: 2018.3.0f2 (6e9a27477296)
    GfxDevice: creating device client; threaded=1
    2019-02-07 02:09:33.214 ArkenforgeLauncher[2337:71878] Dell S2716DG preferred device: NVIDIA GeForce GTX 970 (high power)
    2019-02-07 02:09:33.214 ArkenforgeLauncher[2337:71878] Metal devices available: 1
    2019-02-07 02:09:33.214 ArkenforgeLauncher[2337:71878] 0: NVIDIA GeForce GTX 970 (high power)
    2019-02-07 02:09:33.215 ArkenforgeLauncher[2337:71878] Using device NVIDIA GeForce GTX 970 (high power)
    Initializing Metal device caps: NVIDIA GeForce GTX 970
    Begin MonoManager ReloadAssembly
    - Completed reload, in  0.106 seconds
    OnLevelWasLoaded was found on AudioManager
    This message has been deprecated and will be removed in a later version of Unity.
    Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed
     
    (Filename:  Line: 356)
    
    Receiving unhandled NULL exception
    Obtained 21 stack frames.
  • #22515

    Nathan
    Keymaster

    The ArkenforgeLauncher.app moves itself to a different directory, and is opened by the Arkenforge app.

    Sudo shouldn’t be required anymore. Try running the ‘fix permissions’ app in the utility folder

You must be logged in to reply to this topic.